Follow

How can I download a copy of my invoice?

Symptoms

  • I need to download previous invoices for my subscription
  • I would like a copy of my subscription invoices

Cause

Invoices are only accessed on your Dashboard via your id.unity.com page, providing that you are the Organization owner. Users within an Organization that are assigned the Manager or User roles are not able to view invoices.

Resolution

Users who purchased a license after June 2016, or migrated an old license to the new system:

Owners of Unity Organizations can download subscription invoices through our website:

1. Log in to your account: https://id.unity.com
2. Click "Organizations" shown on the left side of the screen under "My Account".

 

 

3. Select the organization that your subscription license is attached to.


4. Click "Transaction History"


5. Invoices will then be displayed under the "Purchases" tab. You can download invoices by pressing the download button next to the invoice.

 

Users that purchased their license before June 2016:

Your invoices will be emailed to your purchasing email account. If you have inadvertently deleted the email, please contact us with the details of the purchase so that we can locate the invoice in our systems.

More Information

For more information on what Owners can do, please see this article.

For information on how to add users to your Organization, please see this article.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

2 Comments

  • 0
    Avatar
    Katsunori Ogane

    Can I receive my invoice every month by email?

    Is that an option only for users that purchased their license before June 2016?

    Edited by Katsunori Ogane
  • 1
    Avatar
    Unity AJ_KR

    Hi Katsunori, 

    Thanks for the question. 

    Last year, some changes were made on how invoices from your subscription are received.

    These changes were made to tighten our security system in order to protect our users’ information from being exposed by any mistake that we may have in our automated mailing system.

    See above article on how to find this on your account for any future invoices you will need to download.

    I hope this helps,

Please sign in to leave a comment.