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How do I submit a bug report?

Symptoms

  • I have found a bug within my project
  • I am experiencing a bug in the UI system
  • I am experiencing trouble with a game on Facebook

Cause

If Unity is not working like you expect it to this may be due to a technical problem. You may have experienced an issue similar to the following:

  • You have experienced a crash which has closed Unity and is preventing you from re-opening the editor
  • You are receiving an error in your Console.
  • You are experiencing trouble with a published game. This can be caused by a bug in the Unity Web Player

Resolution

The first port of call is to check our Forums and Answers pages. It may be that our Community of users have resolved the issue and posted publicly there.

If you cannot find a workaround, you will need to submit a bug. To submit a bug report, first go into the editor. 

1. Click on Help and select Report a bug from the drop down menu.

2. Specify from the drop down menus what the problem is related to and how often this happens.

3. Enter a valid email address and complete the title and description fields.

4. Finally, click Send to submit your bug report.

Please note, if you cannot get into the Editor, email your issue to bugs@unity3d.com.

When your bug is submitted, you will receive an automatic confirmation email containing your bug number. The QA Team will then assign it to the correct Team to work on a fix.

If your bug does not get a response within 2 weeks, it may be that your specific bug is fixed in a later release, or has available workarounds. You can contact support here to check this.

More Information

For more information on how to report bugs then see the QA Page here

 

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2 Comments

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    Jeff Johnson

    I cannot submit bug reports with Unity 2019.1, it gives a file io error at 2% submission progress.

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    Maru

    Hi Jeff,

    Thank you for your comment.

    I am aware that our QA team know about this which is to do with the provider we have for uploading data to the bug tracker.

    They are working on moving to new infrastructure to avoid this from happening but in the meantime, it is a case of just trying again until it works.

    I've notified the team of your post and asked when this will be fixed so I will certainly reply once I have this information.

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