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Why does the Asset Store say I am offline?

Symptoms

  • Every time I try to download an asset it says "You are currently offline"

Cause

You want to download Assets that you have purchased from the Asset Store. You try to launch your Unity Asset Store account, but you get a window saying that your are offline even though your Internet connection has not dropped.

Resolution

You probably have a firewall or proxy in place. These can block the connection to our servers. To ensure you are not running the Asset Store from behind a proxy server:

  1. Type "configure proxy server" into the Start menu bar.

  2. Click on LAN settings

  3. Uncheck "Use a proxy server for your LAN"

 

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8 Comments

  • 1
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    Scott Hulley

    Didn't fix the problem. It loads but after loading and showing I am online in the top right corner of the AssetStore it says I am offline.

  • 0
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    Thanh Ngo

    Here is how I fixed this issue in Unity 2017:

    (1) Log out of your Unity account:

    Go To "Unity" menu -> click on "Manage License" -> Click on "My Account" -> Click on "Sign out".

    (2) Then exit Unity application.

    (3) Relaunch Unity.

    (4) Try to logon to your Unity account again.

    Next, try to access Unity store again. Be very patient and wait for 2 or 3 minutes, then the internet connection will be established, and everything will be fine.

    Sometimes, I have to repeat these procedure 2 times to make it work.

  • 0
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    louis

    It's a Unity bug - bad login credentials or something.  Log out and then back in to your account should fix it.

  • -1
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    George Papulis

    For me, my Unity Hub had an update.  I updated and restarted my hub, then I was able to access the store in Unity.

  • 0
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    James W

    I seem to get this quite often when I purchase a lot of assets and start clicking the "Open in Unity" buttons.  After 2 or 3 (or more) I get this error.  It forces me to open the asset tab in Unity, then copy-n-paste the name in the search box.  It downloads ok from there.  The "Open in Unity" link is very unreliable and needs work. There needs to be a "recently purchased" list, so I can simply open the asset store tab and just go there after the purchase, because this error is just ridiculous to still be doing this (I've been getting this issue off and on for as long as I've been using 2017 and 2018). Logging out and restarting the app does not already work either, for the record. Also, I do not have a proxy or firewall. In case it helps, I actually clicked a wrong link which took me away from the store, and I clicked the back button to return.  I did refresh the page, but perhaps something timed out, or the store links were no longer valid afterwards.

    Edited by James W
  • 0
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    Gustaf Stechmann

    Had this problem too when using WLAN. Switched to LAN cable seems to have fixed it. 

    It seems that there is a timeout occurring somewhere. Maybe Unity is very impatient and my WLAN is just a tiny bit too slow...

  • 0
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    Eric Adem

    I'm still having this problem.  Tried all the solutions mentioned above and in other threads, but it still says the same thing.  As soon as I want to download something, it switches to a screen that says I'm offline.  I can login fine when I start Unity and can do so on the website as well.  I've tried logging off and back on.  Under My Assets, I can download those just fine, but anything new, it gives me this error.  Is there anyone from Unity support that can actually answer this?  These threads have been going on for several years now, and its preventing people from using one of the most important features of Unity.

  • 0
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    Zappato

    Eric Aden's question came out on Sept. 30th, 2019. Today is November, 14th 2019. Where is Unity's support team, I'm having the same problem.

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