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Why can’t I download an Asset?

Symptoms

  • I have purchased an Asset and have received my PDF invoice.
  • I cannot download an Asset that I have purchased from the Unity Asset Store.

Cause

Assets don't automatically download to your computer upon purchase. You can only download your purchase from within the Unity Editor via the Asset Store window.

Resolution

You need to download your Assets through the Unity Editor. Follow this process:

  1. Open the Unity Editor
  2. Go to Window > Asset Store
  3. Log into the Asset Store using your Unity account details
  4. In the store, search for the Asset you purchased
  5. Click the Download or Import button to download the Asset

If your Asset begins to download but stops halfway through the process, you might be experiencing one of these common connection issues: 

  • You have a firewall or proxy in place, which is blocking the connection to the server. Try allowing these ports in your settings: 80 and 443
  • You have anti-virus software running. Please try disabling this temporarily to download the Asset.
  • You have a weak or intermittent Internet connection. You can check your connection through many speed check sites such as Speed Test. If you do experience weak or intermittent connection issues, speak to your ISP or Network Administrator for further assistance.

Also check that you have enough disk space to download the file, and that the Asset you are downloading fully supports the version of Unity you are using.

More Information

When you download an Asset, it goes to the following directory by default:

Windows: User > AppData > Roaming > Unity > Asset Store

Mac - User > Library > Unity > Asset Store

 

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4 Comments

  • 0
    Avatar
    Jani van den Berg

    My unity engine has not been able to access the store. No one seems to have answers on how to fix this. I do not have a proxy or a firewall. I have great internet and my unity sometimes struggles to connect to my account but at least does it after opening and closing and turning wifi on and off. But I cannot access the asset store. Is there seriously o alternative to download ths than to beg the forums for help. (in which i have not been able to find a solution)

  • 0
    Avatar
    Lily

    Hi Jani! Sorry to hear you are having some problems downloading your asset.

    From your description, it sounds like this problem may be specific to your machine set up. Usually this issue is caused by something blocking the connection such as a proxy, firewall or internet security system.

    If you are still experiencing this issue, please email our Support team on 'support@unity3d.com' to discuss this further.

  • 0
    Avatar
    Karl Schulmeisters

    I have an invoice that reads
    Unity Plus
    Subscription End Date. (one year out)
    Payment Period (current month)
    Essential Pack:
    essential_pack_VR:1

    and yet if I try to download that pack in my Unity editor, I get a prompt to pay for it

     

  • 0
    Avatar
    Lily

    Hey Karl,

    Sorry to hear you have had some problems downloading your Essentials Pack. I can see that you have created a support ticket and one of the team will be able to help you out!

    Please make sure you provide them with your subscription details and Unity account, so they are able to investigate promptly! :)

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