Follow

Why has my subscription license expired?

Symptoms

  • I cannot use my Pro subscription license
  • I have received an email stating that my flexible plan subscription will be deactivated if payments are not made

Causes

Your subscription license can expire if you are out of your 12 month commitment period and part of the flexible plan. If you have missed a payment, there is a 27 day period to give you time to update your details. If the payment has not been made after this, your license will automatically expire.

Resolution

If your subscription is on a flexible plan, it subscription will be deactivated if payments have not been made in the 27 days after the due date.

Unfortunately, once this has happened there is no way to retrieve your subscription. If a Pro subscription is needed, then a new subscription must be purchased and a further 12 month commitment period is necessary.

More Information

For more information, please see the Subscriptions FAQ.

 

Was this article helpful?
0 out of 1 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.