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How do I request a refund on an asset?

Symptoms

  • I have accidentally purchased the wrong asset from the store.
  • I have purchased an asset that does not work as described.
  • I have a duplicate purchase.

Cause

Duplicate purchases may be caused by server errors, or a blip in connectivity locally. These can be refunded by us, though other types of refund request must go through the Publisher of the asset.

Resolution

If you have made a duplicate purchase, please contact us here, so that we can process your refund.

For all other refund requests, please contact the Publisher of the asset directly. They can then support you, or may offer a refund at their discretion.

More Information

 

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8 Comments

  • 1
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    Cwm123

    If we contact the Publisher of the asset directly, and they never respond, how do we process the refund?

  • -1
    Avatar
    Ben

    Hi Cwm123,

    I'm sorry to hear that you are having trouble receiving a reply from the publisher.

    If it has been longer than 5 working days then I'd ask that you contact the support team via support@unity3d.com. The support team will be able to look into helping you further.

  • 0
    Avatar
    Daniel Chaul

    Hi, Im not seeing any email, so how can i contact the publisher to ask a question about the asset before buy the asset? I want to be sure that the asset is useful for my needs. For example i need to ask to the publisher about this asset (https://www.assetstore.unity3d.com/en/#!/content/42992) Thanks and regards

  • 0
    Avatar
    Maru

    Hi Daniel,

    On the asset page linked, you'll see on the bottom right in the main window a 'Publisher's Website' link. Here you should find their contact information. We do advise our Publishers to have some form of support contact method in place so if you are unable to reach them, please let us know in the form of a ticket.

     

     

  • 2
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    Chris Hodge

    Unity,

    Please work on allowing purchasers to refund assets within the store. So many assets on your store claim to do something but fall short on many promises. I am paying through your asset store, I should also be able to refund via the same process. If I want to make something work with my project, of course, I will contact the dev, but if I purchase something that just leaves a bad taste in my mouth after looking it over, allow me to refund it on your end. I've had developers even tell me : Im just learning unity, - or - Gee I haven't tested that. If I spend 50$ on a plugin, I would like to have the confidence knowing what and where it's been tested. On that note, I have a few I would like to be refunded on and see no point in using them, whom can I contact to have the reversals done ? (Even if just for store assets)

  • 1
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    Taly Hotimsky

    Echoing Chris Hodge's comment

    Uncertainty about refund is the key factor that detains me from purchasing assets, especially the more expensive ones.

  • 0
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    Frederic Hein, Blindflug Studios

    Same here, not very user friendly!

  • 0
    Avatar
    Lily

    Hi All,

    Thank you for your feedback on the Asset Store refunds.

    Currently, the process remains that users must contact the asset publisher directly for refund authorization.

    We do, however, appreciate and take on board your comments, as well as, understand the frustrations that may come with this!

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