Follow

Which versions of Xcode does Unity Cloud Build support?

Symptoms

  • I'm encountering errors when I build with certain versions of Xcode.
  • I'm developing for iOS and Mac, and I would like to know which version of Xcode to install.

Cause

You need to know if you should have a specific version of Xcode for using Unity Cloud Build.

Resolution

Generally, Unity Cloud Build uses the latest official Xcode release from Apple, as Apple usually requires apps to be built with the latest versions of Xcode for submission.

When new Xcode versions are released, they're tested with the Unity Cloud Build tools and then released for general use in Unity Cloud Build.

More Information

You may encounter errors if you are using third-party plugins. Plugins need to have an updated Xcode library, so be aware of this when using the Latest Compatible Version of Xcode with third-party plugins

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.